Results 1 to 6 of 6
  1. #1
    Member
    Join Date
    Dec 2005
    Location
    Avondale, AZ
    Posts
    35

    i think i broke it!?

    Well today after i put my alternator pulley on and a new idler i went out for a test drive ans got on it of course, but the first time was the last time considering when i got on it the second time just as i shifted into 3rd a think soemthin went abng the car shut off and i drifted for a while mean while it wouldnt start back up. Now just just my luck it will run but makes a loud ticking or knocking noise. Got it home and checked out the plugs and they seemed to be ok and listen to the valve covers and it also seems ok, i also checked the blower just to make sure so i have no clue what the problem is? whatever it is prob cant be good!!!!!
    2003 SVT Terminator, Red with Black Cobra wheels and a Tan interior.

  2. #2
    Senior Member Venomous Bite's Avatar
    Join Date
    Dec 2005
    Location
    to cool to put it down
    Posts
    219
    It might just be an FRPS or you could have broken it up good. Check the oil and see if it smells like gas if it does then it might only be a blown FRPS.

  3. #3
    Junior Member
    Join Date
    Feb 2006
    Location
    Sierra Vista, AZ
    Posts
    9
    Gold Award 
    I hope it is something small. I keep reading these post and they all end up saying the piston skirt broke. I hope that is not it in your case.
    03 Redfire
    2.93 plus idlers, Xtreme Heat exchanger w/fans, NGK plugs, MRT Catted H, Magnaflow catback, K&N FIPK, and Milehi dyno tune.

  4. #4
    Member
    Join Date
    Dec 2005
    Location
    Avondale, AZ
    Posts
    35
    Yeah same here and what the hell is frsps or whatever lol?
    2003 SVT Terminator, Red with Black Cobra wheels and a Tan interior.

  5. #5
    Senior Member Venomous Bite's Avatar
    Join Date
    Dec 2005
    Location
    to cool to put it down
    Posts
    219
    The FRPS is the fuel rail pressure sensor, the little black box on the driver's side fuel rail.

  6. #6
    Member
    Join Date
    Dec 2005
    Location
    Avondale, AZ
    Posts
    35
    Well guys for those of you who dont know its def broke. Turns out that who ever owned it before had caused it to detonate real bad, prob with a bad dyno tune cause i know that it was tuned before. Now that the top of all the pistons are eaten away, it shot out a part of the ring and sent it throught out the so it destroyed the top of the piston and a scarred up the head alittle. So this just shows how important a good tune is. Even if there has been a bad tune installed on your car before it could still lead to some damage so for you guys that have all this power with a shitty tune i hope you get that tune real quick and if i were u id take it easy until you get that tune.
    2003 SVT Terminator, Red with Black Cobra wheels and a Tan interior.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •