Results 1 to 10 of 10
  1. #1
    Super Moderator Gene's Avatar
    Join Date
    Dec 2005
    Location
    Phoenix
    Posts
    1,224
    Gold Award 

    I might have toasted my engine

    Sorry for the long post, I just need help out on this one. Well, took the car out yesterday to the track and made one pass on the juice. Hit the dirty in second and flet like an animal. I then went to shift into 4th and my car felt like the engine siezed. It just flat out stopped. My buddy said he saw a plume of black smoke when I grabbed 4th. I crused to the turn off lane with no power brakes or stearing. Parked it, popped the hood, my belt was still fine, checked for a gas smell on the dipstick and it was fine. Tried to start it again, wouldnt start. Sat there scratching my head for a few minutes checking vacuum lines and what not and all the major ones were in place. Started it up again and it ran. Drove it to the pit area and checked for codes, no codes. My vaccum was showing 17hg's and fuel pressure guage was normal. So I drove it home not getting into boost and looked it over when I got home. I noticed little cap that popped off of one of the red vacuum lines I capped for the egr delete. I recapped it and now I was pulling 18hg's of vacuum. Could this have caused it to bog and shut down? I'm going to log and beat the piss out of it tonight to see if it happens again. It just scared the piss out of me. The thing I can think of is that I could have had some major spark blow out and thats why it felt like it nosed over (ngk BR7EFS at .032) As soon as it felt shitty, the clutch pedal went in and tossed her in neutral. Perhaps when I went to hit the brakes it stalled? Other than that, I have no clue. I definitley need to run a compression and leak down test.

  2. #2
    Senior Member 50 BMG's Avatar
    Join Date
    Dec 2005
    Location
    AZ
    Posts
    770
    Gold Award 

    Re: I might have toasted my engine

    Quote Originally Posted by Gene
    The thing I can think of is that I could have had some major spark blow out and thats why it felt like it nosed over (ngk BR7EFS at .032).
    First thing I thought of. Hopefully that's what happened.

    Quote Originally Posted by Gene
    Perhaps when I went to hit the brakes it stalled?
    SVC tunes tend to do that; myself and 2 others with SVC tunes have that problem. I forget what it's called, the idle air meter or some shit?


    Anyway's, let us know how the compression test goes...

  3. #3
    Super Moderator Gene's Avatar
    Join Date
    Dec 2005
    Location
    Phoenix
    Posts
    1,224
    Gold Award 
    I dont thinks its correlated to svc tunes, I just think its indicative of the JLT 12" kit. Mine sometimes stalls on me as well, and I hope thats what happened when I let out. I need to buy all the shit for a leakdown and compression test though. Any one have the stuff already?

  4. #4
    Senior Member 50 BMG's Avatar
    Join Date
    Dec 2005
    Location
    AZ
    Posts
    770
    Gold Award 
    Quote Originally Posted by Gene
    I dont thinks its correlated to svc tunes, I just think its indicative of the JLT 12" kit.
    I know it's not the SVC thing, I just like to bitch. Bone stock Ford GT's are having stall problems due to the idle air gadgething.

    The other 2 SVC cars I was referring to don't have the JLT CAI. Do you have a JLT 12" Gene?

  5. #5
    Super Moderator Gene's Avatar
    Join Date
    Dec 2005
    Location
    Phoenix
    Posts
    1,224
    Gold Award 
    Yes sir, I am ordering the revised reducer tomorrow. The one that doesn't look like a ****ing doughnut.

  6. #6
    Senior Member Radeon's Avatar
    Join Date
    Jan 2006
    Location
    Gilbert, AZ
    Posts
    313
    Hey Gene. Time for Cams????
    Future 2008 Shelby GT 500 owner

    2005 Mustang GT-318rwhp
    JLT Intake, Pullies, axleback, SCT w/ bamachips 93 octane race tune.--Gone

    2005 Chevy Tahoe-5.3L 295hp

  7. #7
    Member Screamn03's Avatar
    Join Date
    Dec 2005
    Location
    Union City, CA
    Posts
    40
    I'm not looking at lines or pics right now but could that cap coming off have caused the boost pressure to drop what the FRPS was seeing? I don't mean that the motor lost boost, what I mean is by having a leak maybe it caused a faulty reading to be read by the FRPS (assuming the line is shared).
    -Michael Rudolph-
    Redfire 2003 Cobra
    11.30 @ 129 1.68 60' MT DRs
    11.85 @ 124 1.90 60' street tires

  8. #8
    Super Moderator Gene's Avatar
    Join Date
    Dec 2005
    Location
    Phoenix
    Posts
    1,224
    Gold Award 
    Well, after beating the living piss out of it, its fine. I think I have my plugs gapped too much, I'm dropping them down to .028 I think the stall was just hitting the brakes hard when my idle was at 690, this could have caused the engine to bog and eventually shut off. I remember that I had powerbrakes after the incident for like a second, and then I lost them.

  9. #9
    Senior Member 50 BMG's Avatar
    Join Date
    Dec 2005
    Location
    AZ
    Posts
    770
    Gold Award 
    Quote Originally Posted by Gene
    Yes sir, I am ordering the revised reducer tomorrow. The one that doesn't look like a ****ing doughnut.
    Got a link/phone number and price?

  10. #10
    Super Moderator Gene's Avatar
    Join Date
    Dec 2005
    Location
    Phoenix
    Posts
    1,224
    Gold Award 
    I'll let you know as soon as JLT sends me a response. They stock them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •